Error :MySQL No operations allowed after statement closed


#1

Hi,

I installed Tanaguru locally, followed the Tanaguru installation steps. I actually set up the max_allowed_packet to 64Mb, but I’ve got the following error:

Can you help ?

20-02-2015 10:19:41:251 0    INFO  com.mchange.v2.log.MLog  - MLog clients using log4j logging.
20-02-2015 10:19:41:479 228  INFO  com.mchange.v2.c3p0.C3P0Registry  - Initializing c3p0-0.9.2.1 [built 20-March-2013 10:47:27 +0000; debug? true; trace: 10]
20-02-2015 10:19:45:386 4135 INFO  com.mchange.v2.c3p0.impl.AbstractPoolBackedDataSource  - Initializing c3p0 pool... com.mchange.v2.c3p0.ComboPooledDataSource [ acquireIncrement -> 10, acquireRetryAttempts -> 30, acquireRetryDelay -> 1000, autoCommitOnClose -> false, automaticTestTable -> null, breakAfterAcquireFailure -> false, checkoutTimeout -> 0, connectionCustomizerClassName -> null, connectionTesterClassName -> com.mchange.v2.c3p0.impl.DefaultConnectionTester, dataSourceName -> 1q0jxoc971a4z8fh1m0gqyn|47c65163, debugUnreturnedConnectionStackTraces -> true, description -> null, driverClass -> com.mysql.jdbc.Driver, factoryClassLocation -> null, forceIgnoreUnresolvedTransactions -> false, identityToken -> 1q0jxoc971a4z8fh1m0gqyn|47c65163, idleConnectionTestPeriod -> 3600, initialPoolSize -> 5, jdbcUrl -> jdbc:mysql://localhost:3306/e4zadmaa, maxAdministrativeTaskTime -> 0, maxConnectionAge -> 0, maxIdleTime -> 0, maxIdleTimeExcessConnections -> 0, maxPoolSize -> 1000, maxStatements -> 0, maxStatementsPerConnection -> 0, minPoolSize -> 5, numHelperThreads -> 3, preferredTestQuery -> null, properties -> {user=******, password=******}, propertyCycle -> 0, statementCacheNumDeferredCloseThreads -> 0, testConnectionOnCheckin -> false, testConnectionOnCheckout -> false, unreturnedConnectionTimeout -> 0, userOverrides -> {}, usesTraditionalReflectiveProxies -> false ]

(can’t attache the log file, f*ù$!ng forum tool)


#2

Hi,
Can you give a bit more details cause in your trace, there is no ERROR log?
Version, System, steps to reproduce ?
Did you manage to launch any audit before this error happens?
Can you have a look to your mysql settings, defined in the /etc/tanaguru/tanaguru.conf and make sur you can connect to the database from the parameters you set-up in this file?

Regards

koj


#3

I’ve just changed the settings of the forum, so you can add .txt and .log files (up to 1Mb)

Matthieu


#4

Thanks you @mfaure

HEre is the log file (attached) tanaguru.log (42.9 KB)


#5

Hmmm, could you:

  • please double-check that max_allowed_packet is at 64Mb (instead of 16 by default)
  • verify you disk space, especially for the /var/lib/mysql directory (or anyway where your DB may be stored)

#6

OK thks ! That was the point. The /var/lib/mysql partition was full (1Gb and huge site audit launched)